25 lines
591 B
Nix
25 lines
591 B
Nix
{ nixpkgs ? import <nixpkgs> {} }:
|
|
|
|
let
|
|
purescriptOverlaySrc = nixpkgs.fetchgit {
|
|
url = "https://github.com/thomashoneyman/purescript-overlay.git";
|
|
rev = "1a6676b94f064113980b142454e3eefeecce5dcc";
|
|
sha256 = "sha256-jTGJhKuv/KPsMOnfIUSqoTckf4jo3e+9e0XY2cvXbD4=";
|
|
};
|
|
purescriptOverlay = import "${purescriptOverlaySrc}/overlay.nix";
|
|
pkgs = import <nixpkgs> {
|
|
overlays = [ purescriptOverlay ];
|
|
};
|
|
in
|
|
|
|
pkgs.mkShell {
|
|
buildInputs = with pkgs; [
|
|
purescript
|
|
spago
|
|
purs-tidy
|
|
purs-backend-es
|
|
purescript-language-server
|
|
nixpkgs.pkgs.esbuild
|
|
];
|
|
}
|